algoritmo "calculadora" var: n1, n2, x, resultado, temp1, temp2, temp3, op3, op4: real menu, operacao, unidade, temp, sair, km, m, cm, mm: caractere inicio escreval ("para calculadora simples digite 1") escreval ("para calcular temperatura em graus e kevin digite 2") escreval ("para calcular unidades de medida digite 3") leia (menu)

//calculadora simples escolha menu caso "1" Escreval ("Escolha a operação desejada: + (SOMA) , - (SUBTRAÇÃO), / (DIVISÃO)") escreval ("* MULTIPLICAÇÃO, % PORCENTAGEM") leia (operacao) escolha (operacao)

caso "+" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 + n2) Escreval("O resultado é:", x) caso "-" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 - n2) Escreval("O resultado é:", x) caso "" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <- (n1 * n2) Escreval("O resultado é:", x) caso "/" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) se (n2 = 0) entao escreval(" Erro - impossível dividir por zero. Refaça a operação clicando enter") senao x <- (n1 / n2) Escreval("O resultado é:", x) fimse caso "%" escreval ("digite o primeiro valor") leia (n1) escreval ("digite o segundo valor") leia (n2) x <-(n1n2/100) escreval ("O resultado é:", x) outrocaso escreval(">ERRROOO< Repita a operação!") fimescolha

escreval ("Deseja fazer outra operação? se sim clique enter, se não digite sair") leia (sair)

//calculadora de unidades de unidades

caso "2" escreval ("escolha:") escreval("de:") escreval("1 Graus Celsius(°C)") escreval("2 Graus Kelvin(°K)") leia(temp1) escreval("PARA:") escreval("1 Graus Celsius(°C)") escreval("2 Graus kelvin(°K)") leia (temp2) escolha temp

caso(temp1="1") e (temp2="2") faca escreval("Temperatura em Graus Celsius:") leia(temp3) x<- temp3+273.15 escreval escreval("Temperatura em Graus kelvin:", x ) se (temp1="2") e (temp2="1") faca escreva("Temperatura em Graus kelvin:") leia(temp3) x <- temp3-273.15 escreval escreval("Temperatura em Graus Celsius:", x ) caso (temp1="2") e (temp2="2") entao escreva("Temperatura em Graus kelvin") leia(temp3) escreval("Temperatura em Graus kelvin", x) outrocaso escreval(" >repita a operação!<") fimescolha fimescolha

caso"3" escreval("DE:") escreval("1 Quilômetro(km)") escreval("2 Metro(m)") escreval("3 Centímetro(cm)") escreval("4 Milímetro(mm)") leia(op3) escreval("PARA:") escreval escreval("1 Quilômetro(km)") escreval("2 Metro(m)") escreval("3 Centímetro(cm)") escreval("4 Milímetro(mm)") leia(op4) leia (menu) escolha unidade caso (op3="1") e (op4="1") entao escreval("Distância em Quilômetros(km): ") leia(km) escreval("Distância em Quilômetros: ", km, " km") caso(op3="1") e (op4="2") entao escreval("Distância em Quilômetros(km): ") leia(km) m <- km * 1000 escreval("Distância em Metros: ", m,"m") caso(op3="1") e (op4="3") entao escreval("Distância em Quilômetros(km): ") leia(km) cm <- km * 100000 escreval("Distância em Centímetros: ", cm, "cm") caso(op3="1") e (op4="4") entao escreval("Distância em Quilômetros(km): ") leia(km) mm <- km * 1000000 escreval("Distância em Milímetros: ", mm, " mm") caso(op3="2") e (op4="1") entao escreval("Distância em Metros(m): ") leia(m) km <- m / 1000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="2") e (op4="2") entao escreval("Distância em Metros(m): ") leia(m) escreval("Distância em Metros: ", m, " m") caso(op3="2") e (op4="3") entao escreval("Distância em Metros(m): ") leia(m) cm <- m * 100 escreval("Distância em Centímetros: ", cm, " cm") caso(op3="2") e (op4="4") entao escreval("Distância em Metros(m): ") leia(m) mm <- m * 1000 escreval("Distância em Milímetros: ", mm, " mm") caso(op3="3") e (op4="1") entao escreval("Distância em Centímetros(cm): ") leia(cm) km <- cm / 100000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="3") e (op4="2") entao escreval("Distância em Centímetros(cm): ") leia(cm) m <- cm / 100 escreval("Distância em Metros: ", m, " m") caso(op3="3") e (op4="3") entao escreval("Distância em Centímetros(cm): ") leia(cm) escreval("Distância em Centíetros: ", cm, " cm") caso(op3="3") e (op4="4") entao escreval("Distância em Centímetros(cm): ") leia(cm) mm <- cm * 10 escreval("Distância em Milímetros: ", mm, " mm") caso (op3="4") e (op4="1") entao escreval("Distância em Milímetros(mm): ") leia(mm) km <- mm / 1000000 escreval("Distância em Quilômetros: ", km, " km") caso(op3="4") e (op4= "2") entao escreval("Distância em Milímetros(mm): ") leia(mm) m <- mm / 1000 escreval("Distância em Metros: ", m, " m") caso(op3="4") e (op4="3") entao escreval("Distância em Milímetros(mm): ") leia(mm) cm <- mm / 10 escreval("Distância em Centímetros: ", cm, " cm") caso (op3="4") e (op4="4") entao escreva("Distância em Milímetros(mm): ") leia(mm) escreval("Distância em Milímetros: ", mm, " mm") escreval(">refaça a operação<") fimse fimescolha fimalgoritmo

perguntou Apr 11 às 03:14

paulolimaaf's gravatar image

paulolimaaf
11

fechado Apr 11 às 19:01

marcmira's gravatar image

marcmira ♦
36346228.7k

A pergunta foi fechada pelo seguinte motivo: "Pergunta é fora do escopo ou irrelevante" marcmira Apr 11 às 19:01

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×2,064
×605
×10

pergunta feita: Apr 11 às 03:14

pergunta lida: 159 vezes

última alteração: Apr 11 às 19:01