Estou com um problema ao fazer uma fórmula no excel, peço que me ajudem.

Há uma lista de alunos, onde se tem a nota de cada um, sendo que menor que 5 está reprovado, de 5 a 6,9 está de recuperação e igual ou maior que 7 está aprovado. Efetuado os cálculos colocado as notas na tabela e discriminado em qual parametro se enquadra, existe na plan2 uma segunda tabela com o nome do aluno e sua respectiva mãe, e é necessario inserir na tabela da plan1 o nome da mãe do aluno quando ele estiver reprovado ou de recuperação, se estiver aprovado nao preencher, o exercicio pede que se utilize se e procv em conjunto, ja tentei e nao consegui, como fazer?

perguntou Nov 25 '14 às 16:58

CleberZanella's gravatar image

CleberZanella
1121

editou Nov 25 '14 às 17:00

Olá!

Tentarei ajudar!

Acredito que uma boa forma de resolver será usando as funções "SE" e "PROCV". Caso você não tenha familiaridade com a "função SE", tem uma explicação detalhada em https://www.btmco.com.br/post/funcao-se

Se não tem familiaridade com o "PROCV", vá até o post https://www.btmco.com.br/post/procv

O primeiro passo, será utilizar a "função SE" para determinar quais alunos estão reprovados, em recuperação ou aprovados.

| A | B | C
1| Aluno | Nota | Resultado
2| João | 5,0 | =SE(B2<5;"Reprovado";SE(B2<7;"Recuperação";"Aprovado")
3| Cleber | 7,1 |
4| Ana | 3,9 |
5| Maria | 6,5 |

Após isso, crie mais uma coluna "Nome da mãe" na plan1, e iremos utilizar a "função SE" em conjunto com a "função PROCV".

| A | B | C | D
1| Aluno | Nota | Resultado | Nome da mãe
2| João | 5,0 | Recuperação | =SE(OU(C2="Recuperação";C2="Reprovado"); PROCV(A2;[tabela da plan2];2;FALSO);"")
3| Cleber | 7,1 | Aprovado |
4| Ana | 3,9 | Reprovado |
5| Maria | 6,5 | Recuperação |

Note que o "PROCV" só será executado se a coluna C tiver resultado "Recuperação" ou "Reprovado", essa condição se dá pela função "SE".

Para copiar a função para as próximas linhas, selecione a célula da função, clique no canto direito inferior e arraste. Para isso, garanta que o intervalo procurado no PROCV esteja "travada"(referência absoluta) apertando a tecla F4 ao selecionar o intervalo, ele mudará de "Plan2!A2:B5" para "Plan2!$A$2:$B$5".

link permanente

respondeu Jul 11 às 12:41

RafaBTM's gravatar image

RafaBTM
111

editou Jul 11 às 13:40

Bom dia.

Espero que ajude.

A B C D E F G

1 alunos nota 1 nota 2 nota 3 nota 4 nota final

2 maria 5,60 5,80 7,30 9,00 6,93 APROVADO

3 joão 4,00 0,00 3,80 6,10 3,48 REPROVADO

4 Jose 9,00 8,00 10,00 9,00 9,00 APROVADO

5 mar 7,00 8,00 0,00 5,00 5,00 RECUPERAÇÃO

6 joana 9,00 10,00 5,00 6,80 7,70 APROVADO

FORMULA: =SE(F2<5;"REPROVADO";SE(E(F2>=5;F2<=5,9);"RECUPERAÇÃO";SE(F2>6;"APROVADO";"")))

link permanente

respondeu Jul 11 às 13:45

Leonel_Soares's gravatar image

Leonel_Soares
11

editou Jul 11 às 13:47

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×2,508
×2,013
×34
×23
×13

pergunta feita: Nov 25 '14 às 16:58

pergunta lida: 662 vezes

última alteração: Jul 11 às 13:49