Boa noite!

É possível usar um Case no Excel? Por exemplo: Tenho determinada coluna com códigos, e dependendo do primeiro número deste código, na célula seguinte aparecerá um nome. Se o primeiro número for 3 então o nome na célula seguinte para ele será DIE, se for 2, será ATI..alguma dica de como fazer isso? Obrigada!!

perguntou Apr 07 '15 às 01:30

dri_araujo_2015's gravatar image

dri_araujo_2015
1126

Select Case salario

Case Is <= 1200 taxa = 0 Case 1201 To 2500 taxa = 2 Case 2501 To 5000 taxa = 4 Case Is > 5000 taxa = 6

End Select

Essa é a estrutura basica

Acesse www.forum.techtudo.com.br

link permanente

respondeu Apr 07 '15 às 01:54

tecadvanced's gravatar image

tecadvanced
(suspenso)

editou Apr 07 '15 às 11:31

marcmira's gravatar image

marcmira ♦
36356329.9k

Sim, mas vai ter que usar VBA.

link permanente

respondeu Apr 07 '15 às 10:25

callazzans's gravatar image

callazzans ♦
451210.7k

Direto no excel, sem VBA, você usa a função SE.

Na primeira célula referente aos resultados, aplique a função =SE(B2>=6,5;"Aprovado";"Reprovado") https://www.aprenderexcel.com.br/2013/tutoriais/funcao-se-

link permanente

respondeu Nov 06 '17 às 18:48

VilmarBRO's gravatar image

VilmarBRO
1550

Olá dri_araujo_2015, sim existe sim! É a função PARÂMETRO. =PARÂMETRO(Valor de parâmetro; Valor de correspondência1...[2-126]; Valor para retornar caso haja uma correspondência1...[2-126]; Valor para retornar caso não haja nenhuma correspondência). Caso ainda esteja com dúvida, entre em contato no nosso canal!! https://www.youtube.com/channel/UCn1BgxT5rRXd7LHQgDyd9iw?view_as=subscriber

link permanente

respondeu Dec 31 '18 às 18:14

pauloamericano01's gravatar image

pauloamericano01
11

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×351
×165
×32
×30

pergunta feita: Apr 07 '15 às 01:30

pergunta lida: 9,004 vezes

última alteração: Dec 31 '18 às 18:41