Olá pessoal, Preciso da ajuda de vocês, quanto a uma fórmula para um problema, vou descrever, vejam se conseguem..

Introdução ao problema: Então, em uma coluna A, temos dezenas que vão de 01 (na primeira linha), 02 (na segunda linha), ..., 99 (na 99ª linha) e 00 (na 100ª linha); Na segunda coluna B, temos: na linha 1, 2, 3, 4, na frente das dezenas (01, 02, 03 e 04), colocaremos o número 1; na linha 5, 6, 7, 8, na frente das dezenas (05, 06, 07 e 08), colocaremos o número 2; [...], assim até chegar nas ultimas 4 dezenas, na linha 97, 98, 99 e 00 da coluna B, colocaremos o número 25.

Resumindo: 25 conjuntos de 4 dezenas cada. 1 {01, 02, 03 e 04}; 2 {05, 06, 07 e 08}; 3 {09, 10, 11 e 12}; [...]; 25 {97, 98, 99 e 00}

Continuando o problema: Em uma célula qualquer, vazia. Haverá uma milhar (quatro números), pode ser qualquer uma de 0000 a 9999. Na célula ao lado dela, deverá retornar o número do conjunto o qual a dezena (os dois últimos números) dessa milhar corresponde. Por exemplo: Temos a milhar 3484, os dois últimos números dela é 84, então na célula ao lado dessa milhar, deverá retornar o número do conjunto 21. Pois a dezena 84 pertence ao conjunto 21 {81, 82, 83 e 84}. Mais um exemplo, Temos a milhar 0100, os dois últimos números dela é 00, então na célula ao lado dessa milhar, deverá retornar o número do conjunto 25. Pois a dezena 00 pertence ao conjunto 25 {97, 98, 99 e 00}.


PERGUNTA: QUAL É A FÓRMULA QUE RETORNARÁ O NÚMERO DO CONJUNTO, COM BASE NESSES CRITÉRIOS EXPLICADOS ACIMA?


Quando eu estava tentando, eu fiz assim: =PROCV(DIREITA(G9;2);A1:B100;2;0)

Mas não obtenho resultado esperado, procurei em diversos lugares, mas nada de informação, não sei se a função PROCV não aceita outra função como valor procurado. ):

Vejam se podem me ajudar, por favor... Desde já, obrigado.

perguntou Jun 29 '16 às 23:11

lolHender's gravatar image

lolHender
1111

Olá tudo bem,

Pelo que entendi do seu caso, a formula que foi usada está correta,

Talvez o erro seja ao copiar e colar a formula, pois o intervalo não está bloqueado,

=PROCV(DIREITA(G9;2);A1:B100;2;0)

Tenta bloquear antes de copiar

=PROCV(DIREITA(G9;2);$A$1:$B$100;2;0)

link permanente

respondeu Mar 08 '18 às 18:05

siantos10's gravatar image

siantos10
55831

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×2,805
×2,305
×1,555
×165
×23

pergunta feita: Jun 29 '16 às 23:11

pergunta lida: 776 vezes

última alteração: Mar 08 '18 às 18:05