ESTOU FAZENDO UMA PLANILHA, E GOSTARIA DE SABER SE TEM COMO FAZER UM CONTADOR, EM QUE CADA VEZ QUE EU DER ENTER ELE SOME MAIS 1

perguntou Jun 20 '17 às 16:45

mario_winter's gravatar image

mario_winter
1111

primeiro vc tem de nocao sobre a linguagem de programacao usada nos aplicativos MSOFFICE da Microsoft (Visual Basic Application, VBA) e para facilitar vc pode ativar o GRAVADOR DE MACRO no Excell, no seu caso, para gravar as acoes q vc efetuar na planilha.

por exemplo, preencher uma celula e pressionar o ENTER.

entao, vc para o GRAVADOR DE MACRO e edita a macro q acabou de ser criada ou pelo menos ve os comandos utilizados para ter uma base na sua tarefa especifica na planilha.

porem tem de ter nocao de programacao para comecar.

para saber qual e o evento q e disparado qdo se pressiona uma tecla para entao aumentar o valor do contador....

if tecla = keyEnter then contador = contador + 1

https://msdn.microsoft.com/VBA/Excel-VBA/articles/application-onkey-method-excel

sorte

link permanente

respondeu Jun 20 '17 às 20:02

emailx45's gravatar image

emailx45
5917491

editou Jun 20 '17 às 20:11

Uma maneira bem simples é utilizar uma condicional: =SE(CONT.VALORES(B1)=1;CONT.VALORES($B$1:B1);"")

Explicação: SE(CONT.VALORES(B1)=1 Verifica se foi digitado valor na célula seguinte.

Se houver: CONT.VALORES($B$1:B1); Conta valores dos intervalos (quantidade de linhas) na planilha. Sendo que a Celula B1 está travada (Quando for copiar a formula ela fica bloqueada em todas)

Se não houver: "" Deixa a célula em branco.

link permanente

respondeu Jun 11 às 10:50

rafaelribeiro987's gravatar image

rafaelribeiro987
16

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×3,103
×568
×173
×46

pergunta feita: Jun 20 '17 às 16:45

pergunta lida: 1,036 vezes

última alteração: Jun 11 às 10:50