OLÁ! TENHO NA PLANILHA UMA COLUNA COM MEUS GASTOS COM O VALOR TOTAL NO FIM E UMA OUTRA AO LADO DE STATUS ONDE COLOCO "PG" NAS CONTAS QUE JÁ PAGUEI. GOSTARIA DE SABER COMO FAÇO PRA SEMPRE QUE COLOCAR O "PG", O VALOR TOTAL SEJA SUBTRAÍDO DE ACORDO COM VALOR NAQUELA LINHA?

perguntou Dec 12 '19 às 10:01

romiltonps1975's gravatar image

romiltonps1975
1

Olá!

Tentarei te ajudar!

Eu tentaria um caminho diferente. E se, ao invés, de subtrair esse valor, a gente só somasse os valores em que não tem o "PG" do lado? Assim teria o somatório dos valores que ainda não foram pagos, faz sentido?

Para isso, eu utilizaria a função SOMASE, se você não tem familiaridade com essa função, tem uma descrição detalhada e um exemplo bem legal (e que acho que resolverá o seu problema) em https://www.btmco.com.br/post/funcao-somase .

Exemplificando uma planilha, ficaria assim:

x | A | B
1 | Gasto | Status
2 | 5,00 | PG
3 | 25,00 |
4 | 10,00 |
5 | 50,00 | PG
6 | 7,00 |

Em uma outra coluna, eu colocaria este somatório.

x | A | B | C | D
1 | Gasto | Status | | Total
2 | 5,00 | PG | | =SOMASE(B2:B6;"";A2:A6) 3 | 25,00 | | |
4 | 10,00 | | |
5 | 50,00 | PG | |
6 | 7,00 | | |

Desta forma, o Excel vai somar somente os valores em que está com a célula de status vazia, não levando em consideração aquelas em que você escreveu "PG".

Espero que eu tenha conseguido ajudar de alguma forma, fico à disposição!

link permanente

respondeu Aug 01 às 11:47

RafaBTM's gravatar image

RafaBTM
11

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×184
×50
×9

pergunta feita: Dec 12 '19 às 10:01

pergunta lida: 0 vezes

última alteração: Aug 01 às 11:47