Eu estou fazendo uma agenda no Excel, tenho uma planilha com os dias da semana na coluna A e com a data na coluna B. Eu gostaria que a coluna C me retornasse "folga", caso o dia seja sábado ou domingo. E também gostaria que a coluna C me retornasse "curso", caso o dia seja quarta-feira ou seja a 3º segunda-feira do mês. Com qual fórmula eu consigo fazer isso? Eu tentei usar as seguintes: =se, =ou, =e, mas não consegui.

perguntou Jan 17 às 22:49

mlsantos's gravatar image

mlsantos
11

Edit: Consegui! Se alguém tiver com um problema similar, tá aí a fórmula que usei:

=SE(OU($A35="sábado";$A35="domingo");"Folga";SEERRO(PROCV($B35;curso;4;0);SEERRO(PROCV($B35;feriados;3;0);SEERRO(PROCV($B35;férias;4;0);0))))

Eu criei uma nova planilha e coloquei lá os dias em que tenho curso. Calculei os dias da seguinte forma: =F5+14 (em F5 coloquei uma data de referência em que eu tinha curso, e coloquei mais 14 porque meu curso é quinzenal). Depois selecionei todos os dias e os renomeei como "CURSO". Também fiz o mesmo processo para feriados e minhas férias.

Traduzindo a fórmula, ficaria assim: Se o dia da coluna A for sábado ou domingo, me retorne "Folga". Se a data da coluna B está na matriz curso, me retorne "Curso". Se a data da coluna B está na matriz feriados, me retorne "Feriado". Se a data da coluna B está na matriz férias, me retorne "Férias". Se não for nada disso, me retorne 0.

link permanente

respondeu Jan 18 às 22:40

mlsantos's gravatar image

mlsantos
11

Sua resposta
mudar para preview

Siga esta pergunta

Por Email:

Uma vez que você entrar você poderá se inscrever para todas as atualizações aqui

Por RSS:

Respostas

Respostas e Comentários

Markdown Básico

  • *italico* ou __italico__
  • **negrito** or __negrito__
  • link:[texto](http://url.com/ "Qual é a sua dúvida?")
  • imagem?![alt texto](/path/img.jpg "Qual é a sua dúvida?")
  • lista numerada: 1. Foo 2. Bar
  • para adicionar uma quebra de linha basta adicionar dois espaços onde você gostaria que a nova linha estivesse.
  • tags HTML básicas também são suportadas

Tags

×183
×27
×22

pergunta feita: Jan 17 às 22:49

pergunta lida: 0 vezes

última alteração: Jan 18 às 22:40